
Unit 2 – Enhancing the Use of Software

26   Information Communication Technology — Grade 11 Student Textbook

Enhancing thE 

usE of softwarE

   Unit OUtcOme

 Students will be able to:

  recognise to choose appropriate software tools to solve problems, illustrate ideas, and clarify thinking in 

other subjects chosen for study in Grade 11.

2.1 USING APPLICATION SOFTWARE

Software refers to the operating instructions and applications that allow computers to process the numbers, 

pictures, sounds, and text we enter into them. In Grades 9 and 10, you have studied about Application 

Software. We know that application software is the software that is designed to satisfy a particular need of 

a particular environment. Some examples of application software are:

 (i) Word Processing Software

 (ii) Presentation Software

 (iii) Spreadsheet Software

 (iv) Desktop Publishing Software

 (v) Database Management  Software

 In this Unit, we will enhance the use of application software. 

l word Processing

Overview

Word processing software was originally designed as a replacement for the typewriter. Now-a-days word 

processing program such as MS-Word 2007 can support photos and drawings, mathematical calculations, 

text in table format, text in varying sizes, shapes, colors and even sound bites.

Creating a Document

Using MS-Word 2007, we can create a variety of documents such as memos, letters, reports, research 

papers, brochures, announcements, newsletters, envelops, labels, and much more.

 To start Word 2007, 

 Click Start → All Programs → Microsoft Office → Microsoft Office Word 2007

 A blank document namely Document1 is created. Figure 2.1 shows the Word 2007 document screen 

elements. 

Unit 2   
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Fig. 2.1: Word 2007 document screen elements

 Now, you can type the text as per your need in the document you have just created and save it for 
future use. You can also open an existing document.

Editing and Formatting Documents

You can edit and format word documents using Word’s powerful editing and formatting features. Editing 

includes inserting, replacing, deleting text, using Undo and/or Redo and spell checking etc. Formatting can 
include tasks as changing the font; aligning and indenting text; changing line and paragraph spacing; and 
inserting elements such as bullets, numbers, tables and pictures, etc.

 To edit a document in Word 2007, perform the following steps:

 1. Open a document.

 2. To insert text, position the insertion point in the desired location and then type the text. You can 

delete the text by pressing the Backspace key or Delete key.

 3. If you make a change to text, such as deleting selected text, and then change your mind, use the 

Undo and/or Redo buttons on the Quick Access toolbar.

 4. For spell checking, click the Review tab and then click the Spelling & Grammar button in the Proofing 

group. Ignore or change as needed. Click OK when check is complete.

 5. Save the document by clicking the Save button on the Quick Access toolbar (or press Ctrl + S).

 To format a document in Word 2007, perform the following steps:

 1. Open a document and select some text from the document.

 2. Click the Font group dialog box launcher (or press Ctrl + D).

 3. To change the font, choose desired font. To apply font effects, click desired effect check box.

 4. Click OK.

 5. You can use the various buttons on Paragraph group in Home tab for aligning the text (Left, Center, 
Right, and Justify), line and paragraph spacing, inserting bullets and numbering. 

 6. Save the document.

Section Breaks

Sections are independent parts of the text that can be formatted independently. Section breaks are used to 
create sections within your MS-Word document. To see the section breaks have your non-printing characters 

turned on (use CTRL + SHIFT + 8 or  under Home tab to hide/display the non-printing characters). 
There is no keyboard shortcut to insert a section break.
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 There are situations when you want to insert a section break in a Word document before the application 
does it automatically. Section breaks are very helpful when creating books or reports. For each section, you 
can specify formatting, such as header and footer appearance, sequence of page numbers, page orientation 
(portrait or landscape), and page margins.

 To insert the section breaks, perform the following steps:

 1. Open a word document and type some text in it (if it is newly created).

 2. Place the cursor where you want the section break.

 3. Click the Page Layout tab.

 4. Click the Breaks button (see Fig. 2.2).

 5. You will get a Page Breaks and Section Breaks window (see Fig. 2.3).

    

 Fig. 2.2: Clicking Breaks button  Fig. 2.3: Page Breaks and Section Breaks window

 6. Now you can choose from four types of section breaks: 

 (i) Next Page inserts a section break and starts the new section on the next page. Useful when you 
start a new chapter.

 (ii) Continuous inserts a section break and starts the new section on the same page. Useful when you 
want to have different formatting within one page.

 (iii) Even Page inserts a section break and starts the new section on the next even-numbered page. 
If you want your chapters to always begin on the even page, use this one.

 (iv) Odd Page inserts a section break and starts the new section on the next odd-numbered page. If 
you want your chapters to always begin on the odd page, use this one.

  The most used is Next Page.

 7. Pick the one you want and your section break is in place.

 8. Repeat as many times as needed.

 9. Save the document.

To display/hide the non-printing characters, use CTRL + SHIFT + 8 or  under Home tab.
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Mail Merge

You use mail merge when you want to create a set of documents, such as a birthday invitation that is 

sent to many friends and relatives or a sheet of address labels. Each letter or label has the same kind of 

information, yet the content is unique. For example, in letters to your friends and relatives, each letter can 

be personalized to address each of them by name. The unique information in each letter or label comes 

from entries in a data source.

 To mail merge in Word 2007, perform the following steps:

 1. Click Start Mail Merge in the Start Mail Merge group in the Mailings tab and select the type of 
document you would like to create (see Fig. 2.4).

  For example, you can select Letters, Envelopes, or Labels. Or, select Step by Step Mail Merge Wizard for 
more help creating your document.

 2. Click Select Recipients in the Start Mail Merge group in the Mailings tab to add recipients to the 
mailing. You can select Type New List (see Fig. 2.5). You can also opt to Use Existing List or Select 

from Outlook Contacts.

  

 Fig. 2.4: Clicking Start Mail Merge Fig. 2.5: Clicking Type New List in Select Recipients

 3. In the New Address List box shown in Fig. 2.6, begin entering your contacts (if the predesigned fields 
satisfy your need otherwise you can delete or insert field(s) you want).  

  To delete or add fields to your mail merge document, click the Customize Columns button on the 
New Address List dialog box (see Fig. 2.6). The Customize Address List dialog box opens (see Fig. 2.7). 
Click Add, Delete or Rename to alter the field types. You can also use the Move Up and Move Down 

buttons to rearrange the order of the fields. When you have done all the changes, click OK.

  

 Fig. 2.6: New Address List box to add recipients Fig. 2.7: Customize Address List dialog box

 to the mail merge database for adding and deleting fields
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  After customizing the field(s), if it was required, you can use the Tab key to move between fields 

in the New Address List dialog box. Each set of fields is referred to as an entry. To add additional 

recipients, click the New Entry button. To delete an entry, select it and click Delete Entry. Click Yes 

to confirm the deletion.

  After adding all your recipients, click OK on the New Address List dialog box. Name the data source 

and click Save.

 Useful Tip

After typing the data in the last field of the last record, do not press the Tab key. If you do so, a new blank 

record will be created. 

 4. To insert a field into your document, click Insert Merge Field in the Mailings tab (see Fig. 2.8). Select 
the field you would like to insert. The field name appears where you have the cursor located in 
your document.

  You can edit and format the text surrounding the field. Formats applied to the field will carry over 
to your finished document. You can continue to add fields to your document.

 5. Before you print your letters, you should preview them to check for errors. In particular, pay attention 
to spacing and punctuation surrounding the fields. You should make sure that you have inserted the 
correct fields in the correct places.

  To preview the letters, click Preview Results in Preview Results group in the Mailings tab (see Fig. 2.9). 

Use the arrows to navigate through the letters.

 6. You may notice an error in the data for one of your documents. You cannot alter this data in the 
merge document. Instead, you will have to fix it in the data source. To do this, click Edit Recipient 
List in the Start Mail Merge group in the Mailings tab (see Fig. 2.10). 

   

 Fig. 2.8: Clicking Insert Merge Field  Fig. 2.9: Clicking Preview Results for  Fig. 2.10: Clicking Edit Recipient

 for inserting a field into the document  previewing the Mail Merge letters List for correcting errors in Mail

    Merge fields

  In the box that opens, you can alter the data for any of your recipients. You can also limit the 
recipients. Simply uncheck the box next to recipients’ names to omit them from the merge operation. 
When you have made the corrections, click OK.

 7. After you have reviewed your documents, you are ready to 
finalize them by completing the merge. Click the Finish & Merge 
button in the Finish group in the Mailings tab (see Fig. 2.11).

  You can select Edit Individual Documents, Print Documents, or 
Send E-mail Messages. If you select Print Documents or Send E-mail 
Messages, you will be prompted to enter a range.

 8. Click Edit Individual Documents at the drop down list.
Fig. 2.11: Clicking Finish & Merge for 

finalizing the Mail Merge documents
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 9. At the Merge to New Document dialog box, click the OK button. The letters are merged with the 
records and displayed in a new document.

 10. Save the merged letters in the normal manner and name the document.

Header & Footer

Headers and footers are areas in the top, bottom, and side margins (the blank spaces outside the printing 
area on a page) of each page in a document. You can insert or change text or graphics in headers and 
footers. For example, you can add page numbers, the time and date, a company logo, the document title 
or file name, or the author’s name.

 You can also specify different headers and/or footers for the first page and the rest of the document. 
Or, if you insert section breaks, you can even give every single page in your Word document a different 
header and footer!

 To insert header and footer in Word 2007, perform the following steps:

 1. Open an existing Word document or create a new one and type some text in it.

 2. Click the Insert tab.

 3. Click Header button in the Header & Footer group (see Fig. 2.12).

Fig. 2.12: Clicking Header button 

 4. Click desired option at drop-down gallery (see Fig. 2.13). It inserts a header in the document.

Fig. 2.13: Inserting Header in a document
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You can edit the header by clicking the Insert tab, clicking the Header button in the Header & Footer, and 

then clicking Edit Header at the drop-down list.

 5. Click the Close Header and Footer button in Close group in Design tab (see 
Fig. 2.14) or double-click in the body of the document. This makes the 
document active and dims the header. Now you can edit your document 
text.

 6. To insert footer, click the Insert tab. Click Footer button in the Header & 
Footer group. Click desired option at drop-down gallery. Footer is inserted in the document.

 7. To exit the footer, double-click in the body of the document.

 8. Scroll through the document and observe how the header and footer appear on each page.

 9. Save the document.

You can work with headers and footers the same way you work with the body of your document. You 

can click on buttons in tabs. This means you can change the font and formatting. You can also copy 

text from the body of your document and paste it into a header or footer or vice versa.

l Presentation software

Overview

Presentation software such as MS-PowerPoint 2007 allows users to create slide shows that can be viewed 
on the computer or projected onto a large screen. The shows can include clipart, graphs and charts, photos, 
drawings, video clips, sound, and text. The slide transition effects provide the attention-getting movement 
those appeals to sales people and teachers.

Preparing a Presentation

You can prepare a presentation using a template provided by PowerPoint or create your own presentation. 
Preparing a presentation consists of general steps such as creating and editing slides; adding enhancements 
to slides; and saving, running, previewing, printing, and closing a presentation.

 To start PowerPoint 2007, 

 Click Start → All Programs → Microsoft Office → Microsoft Office PowerPoint 2007

 A blank presentation namely Presentation1 is created. Figure 2.15 shows the PowerPoint 2007 window 

screen elements. 

Fig. 2.15: PowerPoint window screen elements

Fig. 2.14: Clicking Header and 

Footer to exit header 
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 To create and run the presentation with Installed Template, perform the following steps:

 1. Click Office Button.

 2. Click New.

 3. Click Installed Templates option.

 4. Double-click the desired template. 

 5. To run the presentation, click the Slide Show tab and then click From Beginning button in the Start 
Slide Show group.

 6. Read the information in the first slide and then click the left mouse button. Continue reading the 
information in the slides and clicking the left mouse button to advance to the next slide. When a 
blank screen displays, click the left mouse button to end the slide show.

 7. Save the presentation by clicking the Save button on the Quick Access toolbar.

 8. Close the presentation by clicking the Office Button and clicking Close at the drop-down list.

 To create your own presentation, perform the following steps:

 1. Click Design tab.

 2. Click desired theme in Themes group.

 3. To add slide, click Home tab.

 4. Click New Slide button. Enter some text and figures on the slide.

 5. Continue to add more slides if you want.

 6. To save the presentation, click the Save button on Quick Access toolbar.

 7. The Save As dialog box appears. Identify the location to save a file and type presentation file 
name.

 8. Press Enter key.

A placeholder is a location on a slide marked with a border that holds text or an object. You can use keys 

on the keyboard to move the insertion point to various locations within a placeholder in a slide.

 To add transition and transition sound to all slides in presentation, perform the following steps:

 1. Open the presentation.

 2. Click Animations tab.

 3. To add transition, click More button at right side of transition icons and then click desired transition 

at drop down gallery. Finally click Apply To All button.

 4. To add transition sound, click Transition Sound button arrow and then click desired transition at 

drop down gallery. Finally click Apply To All button.

 5. Save the presentation.

 To print the presentation, perform the following steps:

 1. Open the presentation.

 2. Click Office Button.

 3. Point to the Print option, and then click Print Preview.

 4. Click the Print button in the Print group in the Print Preview tab.

 5. At the Print dialog box, click OK.

 6. Click the Close Print Preview button. 
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 7. Switch on the connected printer. Click Print.

 8. At Print dialog box, specify how you want the presentation printed.

 9. Click OK.

Editing and Formatting Slides

You can edit and format slides and slide elements to customize and personalize the presentation. Editing 
can include functions such as rearranging and deleting slides; cutting, copying, and pasting text; changing 
the font, paragraph alignment, and paragraph spacing; and changing the design theme, theme color, and 
theme font. You can add insert clipart images, pictures in presentations. Customization of presentations by 
formatting of objects and text boxes is also possible in PowerPoint 2007.

 To delete and move slides in PowerPoint 2007, perform the following steps:

 1. Open the presentation.

 2. To delete slide, click Slide Sorter button in view area on Status bar. Click desired slide. Press the 
Delete key.

 3. To move slide, click Slide Sorter button in view area on Status bar. Drag slide to desired location.

 4. Save the presentation.

 To cut/copy and paste text in slides, perform the following steps:

 1. Open the presentation.

 2. Select a slide.

 3. To cut and paste text, select the text and click Cut button in the Clipboard group in the Home tab. 
Position insertion point at the desired location and click the Paste button in the Clipboard group.

 4. To copy and paste text, select the text and click Copy button in the Clipboard group in the Home tab. 
Position insertion point at the desired location and click the Paste button in the Clipboard group. 

 5. Save the presentation.

 To apply fonts and font effects, perform the following steps:

 1. Open a presentation.

 2. Select the text.

 3. To change the font and font size, click the desired button in the Font group in the Home tab.

 4. To apply font effects such as bold, italic, underline, case, color etc., click the desired button in the 
Font group in the Home tab.

 5. Save the presentation.

You can apply font by using the Font dialog box that can be opened by clicking the Font group dialog 

box launcher in the Font group in the Home tab.

 To insert an image or clipart in a presentation, perform the following steps:

 1. Open a presentation.

 2. Click the slide on which you want to insert the image or clipart.

 3. Click Insert tab.

 4. Click Picture button or Clip Art button.

 5. At Insert Picture dialog box, navigate to desired folder or at Clip Art task pane, type desired category, 
and then press Enter key.
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 6. Double-click the desired picture file or clip art image. Arrange the picture or clip art in the slide and 

resize it if necessary. 

 7. Save the presentation.

 To insert text box in a presentation, perform the following steps:

 1. Open the presentation.

 2. Click Insert tab.

 3. Click Text Box button.

 4. Click in the slide or drag to create text box.

 5. Save the presentation. 

l Spreadsheets

Overview

Spreadsheet software can be used for both simple and complex calculations. Current versions such as MS-

Excel 2007 can also support graphics and perform some database tasks, such as sorting. 

 Because the formulas are used to do calculations, you can ask, “If I spend only Birr 100 per day on 

coffee in my office instead of Birr 500, how much money will I save at the end of the month?” When you 

replace one value with another, the program will recalculate your budget automatically.  

Creating Workbooks

We know that a document in MS-Excel is made of one or more worksheets. A document in Excel is called a 

workbook. In other words, a workbook is the group of worksheets that belong to the same document.

 To start Excel 2007, 

 Click Start → All Programs → Microsoft Office → Microsoft Office Excel 2007

 Figure 2.16 shows the Excel 2007 screen elements.

Fig. 2.16: Excel 2007 screen elements
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 When you start MS-Excel, it directly creates a workbook for you. Each worksheet in Excel contains 16,384 

columns and 1,048,576 rows. An Excel Workbook initially contains three worksheets labeled Sheet1, Sheet2, 

and Sheet3. You can use that workbook as per your need. At any time, you can create a new workbook. 

 A worksheet is primarily made of cells that are used to enter data. There are different types of values 

that can be entered in a cell. We can enter labels in columns or rows to create the worksheet layout. To 

put a value in a cell, click that cell and type the value you want. We can create formulas to add, subtract, 

multiply, or divide to calculate the desired results.

To create a workbook based on the templates provided by MS-Excel, click the Office Button and click 

New. This would display the New Workbook dialog box. In the left frame, under Templates, you can click 

a category of your choice.

Editing and Formatting Worksheets

The contents of a cell can be edited directly within the cell or in the Formula bar. Clearing a cell can involve 
removing the cell contents, format, or both. The Spelling feature is a useful tool for correcting typing errors 
within a worksheet. After completing a spelling check, you should proofread the worksheet since the 
spelling checker will not highlight all errors and cannot check the accuracy of values.

 To edit a cell in Excel 2007, perform the following steps:

 1. Open the worksheet.

 2. Double-click the cell to be edited.

 3. Insert and/or delete text.

 4. Press Enter key or click another cell.

 5. Save the worksheet.

 To spell check in Excel 2007, perform the following steps:

 1. Open the worksheet.

 2. Click Review tab.

 3. Click Spelling button.

 4. Click Ignore Once, Ignore All, Change, or Add to dictionary as needed.

 5. Save the worksheet.

 You can insert/delete rows and columns using the Insert/Delete button in the Home tab. Also, the contents 
of a cell or the range of cells can be moved and copied to another location in the worksheet.

 To insert/delete rows and columns in Excel 2007, perform the following steps:

 1. Open the worksheet.

 2. Select the rows or columns.

 3. Click Insert/Delete button on the Home tab.

 4. Click Insert Sheet Rows/Insert Sheet Columns. 

  Or

  Click Delete Sheet Rows/Delete Sheet Columns.

 5. Save the worksheet.

 To move or copy cell(s) contents in Excel 2007, perform the following steps:

 1. Open the worksheet.

 2. Select the cell or range of cells, i.e., source cell(s).
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 3. Click Cut or Copy button.

 4. Select starting destination cell.

 5. Click Paste button.

 6. Save the worksheet.

 Excel allows you to apply formatting attributes and add color to enhance the appearance of the worksheet 
and draw a reader’s attention to important titles, totals, or other results.

 To change font, font size and font attributes, perform the following steps:

 1. Open the worksheet.

 2. Select cell(s).

 3. Click Font button arrow or Font Size button arrow or desired attribute button (bold, italic, underline 
etc.).

 4. Click desired font or desired size.

 5. Deselect cell(s).

 6. Save the worksheet.

 1. You can use the Format Cells dialog box (press Ctrl + Shift + F to open the dialog box) from the 

Font tab selected to change the font, font size, font style, and color of text.

 2. Click Undo button on the Quick Access toolbar or press Ctrl + Z to reverse the last action. Click 

Redo button on the Quick Access toolbar or press Ctrl + Y to redo the last action. Excel 2007 stores 

up to 100 actions that can be undone or redone and you can repeat actions as many times as 

you need. Some actions (such as Save) cannot be reversed with Undo.

Using Functions and Creating Charts

Excel’s built-in functions make the task of writing formulas easier. The functions are grouped by category 

such as statistical, financial, data, and logical. The Insert Function dialog box is available to assist us in 
locating and creating function. Charts can be easily created to emphasize or compare data sets.

 To use the built-in functions in Excel 2007, perform the following steps:

 1. Open the worksheet.

 2. Make the desired cell active.

 3. Click the AutoSum  button arrow in the Editing group in the Home tab.

 4. Click the desired function.

 5. Type or select the argument range.

 6. Press Enter key or click Enter button on the Formula Bar.

 7. Save the worksheet.

 To create charts in Excel 2007, perform the following steps:

 1. Open the worksheet.

 2. Select the cells containing the data you want to chart.

 3. Click Insert tab.

 4. Click Column/Pie/Bar button in the Charts group.

 5. Click desired type chart.

 6. Move and/or resize as required.

 7. Apply design options.

 8. Save the worksheet.
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If condition with AND or OR

From Grade 10, you know that “IF” function of Excel is a conditional construct that displays one or the 

other value in a cell based on the condition applied. If the condition is true, one value is displayed otherwise 

the other value is displayed. 

 The syntax of IF function is: 

 IF (Condition, Value if True, Value if False)

 The three items between the parentheses are the arguments of IF function. Here,

 Condition is what you want to test for.

 Value if True is what you want to do if the answer to the first argument is TRUE.

 Value if False is what you want to do if the answer to the first argument is FALSE.

 You can use the AND, OR, NOT, and IF function to create conditional formulas.  

 AND( ): It returns TRUE if all its arguments are TRUE; returns FALSE if one or more argument is 

FALSE. The syntax of AND( )function is: 

 AND(logical1, logical2, ...)

 Here,  logical1, logical2, ...  are 1 to 255 conditions you want to test that can be either TRUE or FALSE.

 For example,

  =AND(TRUE,FALSE) will result FALSE.

  =AND(3+4=7,3+5=8) will result TRUE.

 Now, open a new spreadsheet, and perform the following steps: 

 1. Widen the B column, as we will be putting a message in cells B2 and B3. 

 2. Now click in cell A1 and type Data, click in cell B1 and type Description(Result).

 3. Type the numbers 40 and 105 in cells A2 and A3 respectively. Now, type the formulas 

  =AND(1<A2,A2<100) and

  =IF(AND(1<A3,A3<100),A3,”The value is out of range”) 

  in cells B2 and B3 respectively.

  Press Enter key to see the results. Figure 2.17 shows the result of these formulas. 

Fig. 2.17: Use of AND

 In the above example, make sure that all the commas and double quotes are in the correct place; 

otherwise Excel will give an error message.
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 OR(  ): It returns TRUE if at least one of the arguments is TRUE; returns FALSE if all arguments are 

FALSE. The syntax of OR( )function is: 

 OR(logical1, logical2,...)

 Here,  logical1, logical2,...   are 1 to 255 conditions you want to test that can be either TRUE or FALSE.

 For example,

  =OR(TRUE) will result TRUE.

  =OR(3+4=8,3+5=9) will result FALSE.

 Again, open a new spreadsheet, and perform the following steps: 

 1. Widen the B column, as we will be putting a message in cells B2 and B3. 

 2. Now click in cell A1 and type Data, click in cell B1 and type Description(Result).

 3. Type the numbers 40 and 105 in cells A2 and A3 respectively. Now, type the formulas

  =OR(1>A2,A2>100) and

  =IF(OR(1<A3,A3<100),A3,”The value is out of range”) 

  in cells B2 and B3 respectively.

 Press Enter key to see the results. Figure 2.18 shows the result of these formulas. 

Fig. 2.18: Use of OR

Activity 2.1
Use AppropriAte softwAre tools e.g., spreAdsheet pAckAge to solve A MAtheMAticAl 

probleM

In small groups, the students will use appropriate software tools e.g., spreadsheet package to solve mathematical 

problem.

Problem: Suppose we want to find the distance traveled if an athlete runs around a football field five, six and 

seven times. It is given that the length of the field is 109.80 meters and its breadth is 48.80 meters.
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Formula Used: The distance traveled is simply the field’s perimeter multiplied by the number of laps.

The perimeter of a rectangular field is the sum of the distances of each side of the field, or

  Perimeter = 2 × (Length + Breadth) units

Using Spreadsheet Package to Solve the Problem

Excel is very useful when solving algebraic equations. The program, however, will not actually perform itself any 

algebraic operations; you must supply the proper formula.

 To solve the given problem using Excel 2007, perform the following steps:

 1. Start MS-Excel 2007.

 2. Open a new worksheet. Widen the cells so that the data and results may be visible properly.

 3. Type the data in the cells (see Fig. 2.19).

 4. Click cell D3. Type the formula =A3*2*(B3+C3) in Formula Bar and press Enter key.

 5. Excel calculates and displays the result in cell D3 (see Fig. 2.19).

 6. Copy and paste the formula of cell D3 in cells D4 and D5 to get the other two results in cells D4 and 

D5 (see Fig. 2.19). The worksheet may look like the following: 

Fig. 2.19: Solving a mathematical problem using Excel 2007

 7. Save the worksheet for future use.

 8. Close MS-Excel 2007.

l Publishing software

Overview

Desktop publishing programs are used to create professional quality documents that combine text and 

other visual elements in non-linear arrangements. MS-Publisher 2007 is designed specifically to handle the 

various desktop publishing needs of individuals and small organizations. 

 Publisher makes it easy to efficiently create a wide range of publications, from simple flyers (one-page, 

one-sided publications that are designed to be read at a glance) to complex brochures. Even novice users 

are able to work productively in Publisher.
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Creating New Publication

When you first start Publisher 2007, you see the Getting Started with Microsoft Office Publisher 2007 window, 

from which you can start a new publication or open an existing one.

 To start Publisher 2007, 

 Click Start → All Programs → Microsoft Office → Microsoft Office Publisher 2007

 The Getting Started with Microsoft Office Publisher 2007 window opens (see Fig. 2.20).

Fig. 2.20: Publisher 2007 Getting Started window

 To create and save a publication based on a template, perform the following steps:

 1. Choose a publication type from Publication Types in the left pane of the Getting Started with Microsoft 

Office Publisher 2007 window.

 2. In the Publication Types list, click the publication category you want.

 3. In the right pane, set the publication options and then click Create.

  A publication based on the selected template opens in a new Publisher program window  

(see Fig. 2.21)

Fig. 2.21: Publisher 2007 program window screen elements
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  The Publisher program window displays all the tools you need to customize the publication. You 

can perform most tasks by clicking commands on menus or buttons on toolbars. Common tasks are 

available in the Format Publication task pane to left of the publication workspace.

 4. To save a publication, click Save As on the File menu.

 5. Click the New Folder button on the toolbar of the Save As dialog box.

 6. Type a name for the folder, press Enter key and name the file if necessary.

 7. Click Save.

	  Useful Tip

If you are already working on a publication, then you can display the Getting Started with Microsoft Office 

Publisher 2007 window by clicking New on the File menu (but not by clicking the New button on the Standard 

toolbar).

 To open an existing publication, perform the following steps:

 1. Open Publisher 2007.

 2. In the Recent Publications pane of the Getting Started with Microsoft Office Publisher 2007 window, click 

From File.

 3. In the Open Publication dialog box, browse to and select the file you want to open.

 4. Click OK.

 To print preview and print a publication, perform the following steps:

 1. Open the publication you want to print.

 2. To print preview it, on the Standard toolbar, click the Print Preview button. Click Close to Close Print 

Preview.

 3. To print it, on the File menu, click Print.

 4. In the Print dialog box, make the settings as per your need.

 5. Click OK.

 6. Click Close on the File menu.

	  Useful Tip

If several publications are open and you want to quit Publisher, you do not have to close the publications 

first. You can simply click Exit on the File menu.

 To create a business card, edit a logo and add it to the Content Library, perform the following steps:

 1. In the Publications Types list, click Business Card. In the center pane, click the design you want.

 2. In the right pane, under Customize, select the Color scheme, Font scheme, and Business Information.

 3. Under Options, select the Page size and whether to include a logo image. Then click Create.

 4. On the Objects toolbar, click the Design Gallery Object button, and in the left pane of the Design 

Gallery, click Logos. If necessary, enlarge the gallery window by dragging its border so that you can 

see the logos in the center pane.
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 5. In the center pane, click the style of logo you want to create, set any other options necessary, and 

then click Insert Object.

 6. Now drag the logo to the area of the publication you want.

 7. On the Arrange menu, click Ungroup, and then click a blank area of the publication to release the 

selection and enable editing of the individual logo elements.

 8. Finally make any edits and add any images you want to the logo. Then select the elements in the 

logo (hold down the Shift key as you click each item), and group them.

l Database Management 

Overview

Database software such as MS-Access 2007 is designed to keep track of information. They allow you to 
rearrange it alphabetically, numerically, or chronologically. Or you can filter the data to display only those 

items that match your criteria, such as names of students who scored more than 90% marks in Grade 10.

 Database software can easily do calculations, such as showing monthly subtotals and an annual total 

for school expenses, but complex mathematical calculations should be done using the spreadsheets.

 Table 2.1 shows some database objects.

Table 2.1: Some Database Objects

Object Description

Table Organizes data in fields (columns) and records (rows). A database must 
contain at least one table. The table is the base upon which other objects are 

created.

Query Used to display data from a table that meets a conditional statement and/or 
to perform calculations. For example, display only those records in which the 
city is Addis Ababa.

Form Allows fields and records to be presented in a different layout than the 
datasheet. Used to facilitate data entry and maintenance.

Report Prints data from tables or queries.

 Table 2.2 shows the basic elements of a database.

Table 2.2: Basic Elements of a Database

Element Description

Field A single component of information about a person, place, item, or object.

Record All fields related to one logical unit in the table such as a student, 
teacher.

Table All of the related records for one logical group.

Database A file containing related tables and objects.

A primary key is a field, which provides a unique identification for each record in the table. The primary 

key must contain unique data for each record. 
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Creating Database

A database is comprised of a series of objects used to enter, manage, and view data. In a database the 

data is organized in the form of tables. A table contains information for related items such as students, 

employees, and inventory etc., broken down into individual units of information. Access 2007 is different 

from the other applications within the Microsoft Office suite 2007. 

 To start Access 2007, 

 Click Start → All Programs → Microsoft Office → Microsoft Office Access 2007

 The Getting Started with Microsoft Office Access window opens (see Fig. 2.22).

Fig. 2.22: Getting Started with Microsoft Access screen

 Click the Office Button and then click Open at the drop-down menu, or click the More hyperlink in the 

Open Recent Database pane or click the name of an existing database in the Open Recent Database pane.

 The Access 2007 screen appears (see Fig. 2.23). 

Fig. 2.23: Access 2007 screen elements



Unit 2 – Enhancing the Use of Software

 Information Communication Technology — Grade 11 Student Textbook  45

 When you create or open a database, it opens in a database window. The navigation pane displays the 

names of objects (e.g., Tables, Queries, Forms, and Reports etc.).

 To open and close the existing objects in Access 2007, perform the following steps:

 1. Start Access 2007.

 2. Open the database file.

 3. Double-click object name in navigation pane (it displays the names of the objects within the database 

grouped by tables).

 4. Click the Close button at the top of right corner of the work area.

 5. Click the Office Button and then click Close Database at the drop-down menu.

 To add records to an existing table in Datasheet view, perform the following steps:

 1. Open the table.

 2. Click the New (blank) record button in the Record Navigation bar or click New button in the Records 

group in the Home tab.

 3. Type data in the fields. When you press Tab or Enter key after typing the last field, the record is 

saved automatically.

 4. Close the table.

 To add records to an existing table in Form view, perform the following steps:

 1. Open the form.

 2. Click the New (blank) record button in the Record Navigation bar or click New button in the Records 

group in the Home tab.

 3. Type data in the fields. When you press Tab or Enter key after typing the last field, the record is 

saved automatically.

 4. Close the table.

 To delete records in a datasheet and form, perform the following steps:

 1. Open the table datasheet or form.

 2. Make the record to be deleted active.

 3. Click Delete button in the Records group in the Home tab.

 4. Click Yes.

 1. Always back up the database file before deleting record(s).

 2. Check that you are deleting the correct record before clicking Yes. Click No if you have selected 

the wrong record by mistake.

 3. The field values in ID (when you create a new table by adding records, Access 2007 automatically 

includes a field named ID that is defined as the primary key) are not dynamic—they do not 

change once the number has been assigned in the field. The numbers in the navigation bar are 

dynamic and update to reflect the current number of records that exist in the table.

 To sort records by single field, perform the following steps:

 1. Open the table to be sorted.

 2. Click in the column by which you want to sort.
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 3. Click Ascending or Descending button in the Sort & Filter group in the Home tab.

 4. Close the table. Access saves the sort order when the table is closed.

 To create a table by adding records, perform the following steps:

 1. Click the Create tab.

 2. Click Table button in the Tables group.

  A blank datasheet appears. Notice that a column with the field name ID has been created 

automatically. Access 2007 creates ID as an AutoNumber field in which the field value is assigned 

automatically as you enter each record.

 3. Type records in blank datasheet.

 4. Double-click Field1.

 5. Type desired field name.

 6. Press the Enter key or click outside field.

 7. Repeat Steps 4–6 for remaining columns of the table.

 8. Click the Save button on the Quick Access toolbar.

 9. In the Save As dialog box, type the name of the table.

 10. Press the Enter key or click OK.

 To create a table in Design View in Access 2007, perform the following steps:

 1. Click the Create tab.

 2. Click Table Design button in the Tables group.

 3. Type the field names, change data types, add descriptions, or modify other field properties, as you 

want.

 4. Assign primary key (make active desired primary key field and click Primary Key button in the Tools 

group in the Table Tools Design tab).

 5. Click the Save button on the Quick Access toolbar.

 6. In the Save As dialog box, type the name of the table.

 7. Press the Enter key or click OK.

Creating Queries and Forms

Queries and forms are objects based on tables and are created to extract, view, and maintain data. Queries 

can be used to view specific fields from tables that meet a specific criterion. Forms provide a user-friendly 

interface for entering, editing, deleting, and viewing records in tables. 

 To create a query in Design view in Access 2007, perform the following steps:

 1. Click the Create tab.

 2. Click the Query Design button in the Other group.

 3. Double-click the required table in Show Table dialog box.

 4. Close the Show Table dialog box.

 5. Add the required field names from the field list box to columns in the design grid.

 6. Click the Save button.

 7. Type the query name and click OK.
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 8. Click the Run button in the Results group in the Query Tools Design tab. The result is displayed in 

Datasheet view.

 9. Close the query.

 To create a form in using Form Wizard in Access 2007, perform the following steps:

 1. Click the Create tab.

 2. Click More Forms button in the Forms group.

 3. Click Form Wizard at the drop-down list.

 4. Choose the table for which you want to create form.

 5. Select fields to include in the form.

 6. Click Next.

 7. Choose the form style.

 8. Click Next.

 9. Type the form title.

 10. Click Finish. The completed form appears in Form view in the work area.

 11. Close the form.

Main/Sub Reports

A sub report is a report that is inserted in another report. When you combine reports, one of them must 

serve as the main report that contains the other report. A main report is either bound or unbound. A bound 

report is one that can display data and has a table or query specified in its Record Source property. An 

unbound report is one that is not based on a table or query (that is, the Record Source property of the report 

is empty).

 We create reports to generate professionally designed printouts of information from tables or queries. 

 To create report using Report tool, perform the following steps:

 1. Click Table object in the navigation pane. Here, we select STUDENT table.

 2. Click Create tab (see Fig. 2.24).

Fig. 2.24: Clicking Create tab
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A table or query must be selected first before clicking the Report button (see Fig. 2.24).

 3. Click the Report button in the Reports group. A report is generated (see Fig. 2.25).

Fig. 2.25: A created report

 4. Save the report.

 To insert a subreport in a report, perform the following steps:

 1. Open the main report in Design view. Then double-click the Report Selector to display the Property 

sheet pane (see Fig. 2.26).

Fig. 2.26: Preparing to create a subreport

 2. On the Data tab, click the Record Source arrow, and select the table or query on which the subreport 

will be based.

 3. On the Design contextual tab, in the Controls group, click the Subform/Subreport button , and then 

click a point on the main report. The SubReport Wizard appears (see Fig. 2.27).
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Fig. 2.27: SubReport Wizard

 4. In the SubReport wizard, with the Use existing Tables and Queries option selected, click Next.

 5. In the Tables/Queries list, click the source you want to use.

 6. In the Available Fields list, double-click the fields you want to move them to the Selected Fields list, 

and then click Next.

 7. Click Next and then click Finish. The subreport will be inserted in the report (see Fig. 2.28).

Fig. 2.28: A subreport

 8. Double-click on the subreport in the Navigation Pane to see its contents (see Fig. 2.29).

Fig. 2.29: Contents of the subreport

 9. Save the subreport.

Group Section

Grouping allows you to separate groups of records visually and to display introductory and summary 

data for each group.
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Group Records in the Report Wizard

Grouping lets you organize and arrange records by group, such as Sex (male or female) or by Region etc. 

Groups can be nested so that you can easily identify the relationships among the groups and find the 

information you want quickly. You can also use grouping to calculate summary information, such as totals 

and percentages.

 To create group records in a report, perform the following steps:

 1. Start MS-Access 2007. Click the table name in the Navigation pane. Here, we select STUDENT.

 2. On Create tab, in the Reports group, click Report Wizard. Access starts the Report Wizard (see Fig. 2.30).

Fig. 2.30: Report Wizard

 3. Select the desired fields.

 4. Click Next.

 5. On the page of the Report Wizard that asks Do you want to add any grouping levels?, click one of the 
field names in the list, and then click Next (see Fig. 2.31). To add grouping levels, double-click any 

of the field names in the list to add them to your report. 

Fig. 2.31: Adding grouping
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  You can also remove a grouping level by double-clicking it in the page display on the right side of 

the dialog box. Use the arrow buttons to add and remove grouping levels, and adjust the priority 

of a grouping level by selecting it and clicking the up or down priority buttons. Access adds each 

grouping level and shows it nested within its parent grouping level.

 6. Click Grouping Options to display the Grouping Intervals dialog box for selecting a grouping interval 

(if you want), then click OK. 

 7. Follow the directions on the remaining pages of the Report Wizard. On the last page, you can edit 

the title of the report. This title will be displayed on the first page of the report, and Access will also 

save the report, using the title as the document name. You can edit both the title and the document 

name later. 

 8. Click Finish. Access automatically saves the report and displays it in Print Preview, which shows you 

the report as it will look when printed. Figure 2.32 shows the grouped records in the report.

Fig. 2.32: Grouped records in a report

   Key ConCepts

  Word processing program such as MS-Word 2007 can support photos and drawings, mathematical calculations, 

text in table format, text in varying sizes, shapes, colors and even sound bites.

  Mail merge is used to create a set of documents, such as birthday invitation that is sent to many friends and 

relatives or a sheet of address labels.

  Presentation software such as MS-PowerPoint 2007 allows users to create slide shows that can be viewed on 

the computer or projected onto a large screen.

  Spreadsheet software such as MS-Excel 2007 can be used for both simple and complex calculations.

  Desktop publishing software such as MS-Publisher 2007 is designed specifically to handle various desktop 

publishing needs of individuals and small organization.

  Database software such as MS-Access 2007 is designed to keep track of information.

Review Questions

Fill in the Blanks

 1. ...................................... is the software that is designed to satisfy a particular need of a particular 

environment.

 2. You use ...................................... when you want to create a set of documents, such as a birthday invitation 

that is sent to many friends and relatives or a sheet of address labels.
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 3. ...................................... programs are used to create professional quality documents that combine text and 

other visual elements in non-linear arrangements.

 4. In a ...................................... the data is organized in the form of tables.

State Whether True or False

 1. Word processing software was originally designed as a replacement for the typewriter.

 2. Spreadsheet software such as MS-Excel 2007 cannot be used for both simple and complex calculations.

 3. The Publisher program window displays all the tools you need to customize the publication.

 4. In a database, a sub report is a report that is inserted in another report.

Multiple Choice Questions

 1. ...................................... are used to create sections within a MS-Word document.

  (a) Section breaks (b) Mail break (c) Slide show (d) Brochures

 2. In MS-PowerPoint 2007, clicking Slide Show button in View area on Status bar will 

  (a) Save Presentation (b) Print Presentation (c) Run Presentation (d) Check Spelling

 3. In MS-Excel, you can create If condition using

  (a) AND (b) OR (c) Both (a) and (b) (d) None of these

 4. How many database(s) can be open at a time in MS-Access 2007?

  (a) Any number (b) Three (c) Two (d) One 

Match the Following

   Column A  Column B

 1. Document creation (a) 

 2. Financial calculation (b) 

 3. Database management (c) 

 4. Present information (d) 

 5. Desktop publishing (e) 

Answer the Following

 1. What is word processing? Describe mail merge in Word 2007.

 2. Give the steps to insert an image or clipart in a presentation in PowerPoint 2007.

 3. What is spreadsheet? Describe IF condition with AND or OR in Excel 2007.

 4. Name some publications that you can publish with Publisher 2007. Give the steps to  create and save a 

publication based on a template.

 5. Describe main/subreport in Access 2007.

Suggested Activities

 1. Use the correct software tool and enhance the knowledge of IT at the same time as the chosen subject.

 2. Use appropriate software tools e.g., spreadsheet package to solve a mathematical problem.

Field Trip

 Using the Internet or computer magazines, look up information on Microsoft Office 2010. List any features 

you find. List which of these features appeal to you and describe why they do.
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